Ignore:
Timestamp:
08/01/05 08:46:01 (9 years ago)
Author:
xi
Message:

Python 2.2 compatibility (sort of).

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/lib/syck/loaders.py

    r16 r18  
    11 
    2 """ 
    3 sdgsdf gsfdg sfdg sfd gsdfg 
    4 """ 
     2# Python 2.2 compatibility 
     3from __future__ import generators 
     4 
     5try: 
     6    import datetime 
     7except ImportError: 
     8    pass 
     9 
     10try: 
     11    import sets 
     12except ImportError: 
     13    class _sets: 
     14        def Set(self, items): 
     15            set = {} 
     16            for items in items: 
     17                set[items] = None 
     18            return set 
     19    sets = _sets() 
    520 
    621import _syck 
    722 
    8 import re, datetime, sets 
     23import re 
    924 
    1025__all__ = ['GenericLoader', 'Loader', 
     
    1227 
    1328class GenericLoader(_syck.Parser): 
    14     """ 
    15     ssdfg sfdgs dfgsdfgs 
    16     sdfgs dfgsfdgsfgsfdgsfdg sdfg 
    17     """ 
    1829 
    1930    def load(self): 
Note: See TracChangeset for help on using the changeset viewer.