Ignore:
Timestamp:
05/30/11 00:19:04 (3 years ago)
Author:
xi
Message:

Dropped support for Python 2.3 and 2.4.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • pyyaml/trunk/lib/yaml/constructor.py

    r377 r380  
    77 
    88import datetime 
    9  
    10 try: 
    11     set 
    12 except NameError: 
    13     from sets import Set as set 
    149 
    1510import binascii, re, sys, types 
     
    503498                    "expected non-empty name appended to the tag", mark) 
    504499        if u'.' in name: 
    505             # Python 2.4 only 
    506             #module_name, object_name = name.rsplit('.', 1) 
    507             items = name.split('.') 
    508             object_name = items.pop() 
    509             module_name = '.'.join(items) 
     500            module_name, object_name = name.rsplit('.', 1) 
    510501        else: 
    511502            module_name = '__builtin__' 
Note: See TracChangeset for help on using the changeset viewer.