Modify

Ticket #28 (closed defect: worksforme)

Opened 8 years ago

Last modified 8 years ago

Incorrect handling of strings with trailing spaces

Reported by: yang Owned by: xi
Priority: highest Component: pysyck
Severity: major Keywords:
Cc:

Description (last modified by xi) (diff)

The following fails because the trailing space is dropped. I don't know if this is incorrect dumping (should've quoted), loading (should not have ignored the space), or even both.

s = 'abc '
assert syck.load( syck.dump(s) ) == s

Attachments

Change History

comment:1 Changed 8 years ago by anonymous

Should've used preview....

s = 'abc '
assert syck.load( syck.dump(s) ) == s

comment:2 Changed 8 years ago by xi

  • Status changed from new to closed
  • Resolution set to worksforme
  • Description modified (diff)

It seems you are using some older version of libsyck. I'd recommend you to install libsyck from svn:  http://code.whytheluckystiff.net/svn/syck

Note that this is not a bug in pysyck, Python bindings to libsyck.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.