Modify

Ticket #93 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

setup.py install --record-rpm lists _yaml.so even if not build

Reported by: werner.ho@… Owned by: xi
Priority: low Component: pyyaml
Severity: normal Keywords:
Cc:

Description

pyyaml version 3.06. the bug wasn't there in 3.05

I'm installing pyyaml with the following command to create an rpm package:

python setup.py install --prefix=%{_prefix} \
		--root=$RPM_BUILD_ROOT \
		--record-rpm=INSTALLED_FILES

Inside the file INSTALLED_FILES the _yaml.so file is listed even if that file is not installed.

/usr/lib64/python2.5/site-packages/yaml/resolver.pyc
/usr/lib64/python2.5/site-packages/yaml/scanner.pyc
/usr/lib64/python2.5/site-packages/_yaml.so
/usr/lib64/python2.5/site-packages/PyYAML-3.06-py2.5.egg-info
%dir /usr/lib64/python2.5/site-packages/yaml

Workaround: Either remove that line from the file before packaging or just do not use the file listing.

Regards Werner

Attachments

Change History

comment:1 Changed 5 years ago by xi

  • Status changed from new to closed
  • Resolution set to fixed

--record-rpm is a non-standard distutils extension so I cannot reproduce this bug. However I hope this problem was fixed in [301]. I'm closing this ticket, but feel free to reopen it if the problem persists.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.